Back
Maintenance
Maintenance
Scheduled system maintenance
Completed 30 Aug at 07:00am CEST.
https://transmind.me
https://staging.transmind.me
Completed
Maintenance completed
Posted
30 Aug at 07:00am CEST.
Started
The system is currently undergoing scheduled maintenance which will affect a limited number of customers.
Posted
30 Aug at 06:30am CEST.